[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: The Continuing Saga of the Kernel that Now Boots, but doesn't Work

On Fri, 2002-03-01 at 18:39, Timothy R. Butler wrote:
> Hi everyone,
>   Anyone who has been following the threads "Linux Progress Patch (Splash 
> Screen)" and "The Kernel that Wouldn't Boot," have probably gotten really 
> tired of hearing about my little kernel. 
>   Well, hopefully I'll finally have it fixed soon, so not to worry. :-) 
> Anyway, my kernel now boots, but many of the modules have undefined symbols. 
> I have tried rebuilding the modules. As an example, here is the output I get 
> if I try to initialize my mouse (insmod'ing hid, mousedev, usb-uhci, etc.):
> ----------------------------------------------------------------
> /lib/modules/2.4.17/kernel/drivers/usb/usb-uhci.o: unresolved symbol 
> usb_free_dev_Ra38257d3
> /lib/modules/2.4.17/kernel/drivers/usb/usb-uhci.o: unresolved symbol 

I've had problems compiling kernels when I've compiled for SMP and later
tried to build an UP kernel from the same tree.  Make clean did not get
rid of all the SMP cruft.  So try this:

1. delete this kernel tree
2. Get the 2.4.17 tar ball and signature file.  You need GnuPG setup to
check the signature.  Basically, download the kernel GPG signature into
your local keyring.  Then you can verify the tar ball is good. 
Otherwise, check it with gunzip -vt or bunzip2 -vt.
3. Apply your patch and make sure it applied correctly.  Save the output
from patch.
4. make mrproper
5. make clean
6. make menuconfig
7. If you want multiple versions of the same kernel, i.e. compiled with
different options, edit Makefile and change subversion.  If you don't do
this then make modules_install will overwrite your /lib/modules/2.4.17
dir tree.
7. make dep
8. make bzImage
9. make modules
10.  If a /lib/modules/<your kernel version> dir exists delete it before running make modules_install.
11. copy arch/i386/boot/bzImage to /boot/vmlinuz-<your kernel version>
and setup lilo or grub.  I also copy System.map & .config

After booting the new kernel make sure your modules config is setup
properly in /etc.  If you change any module config remember to run

hope this helps

Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: