[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dpkg error?

On Sunday 03 February 2002 12:55 pm, Jan-Hendrik Palic wrote:
> Hi ...
> On Sat, Feb 02, 2002 at 12:14:58PM -0900, Greg C. Madden wrote:
> >I removed gpm with: 'update-rc.d -f gpm remove' then 'dpkg -P gpm'
> >Apparently this did not remove a reference to gpm somewhere in the
> > dpkg system. Dselect will not install new packages as it fails with
> > the following messages: 
> why did you not purge gpm with dpkg -P gpm only?
> It will work as well. If you will do so, without update-rc.d -f gpm

Thanks for the info, I was under the (mistaken?) impression that 
'update-rc.d' removed the links from ~/init.d/ to the various run 
levels, so I used it first, (I thought it would leave the gpm script in 

Then on some subsequent update gpm  was being reinstalled/reconfigured 
so I did the 'dpkg -P' to not have any more references to it on my box. 
I have already ran 'dpkg -P' and didn't notice the error messages until 
I tried using dselect, I usually use 'apt-get' 

> Because of the running update-rc.d -f gpm remove before purging gpm,
> there is no /etc/init.d/gpm, so the dpkg is not able to purge gpm at
> all. Look intp /var/lib/dpkg/info/gpm.prerm, there will be a test
> like
>   if /etc/init.d/gpm stop; then return 0; fi
> comment or delete this line, and  then, dpkg -P will work.

I renamed the file ~.save and dselect worked :)

Greg Madden

Reply to: