[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: cups+samba

On Fri, Feb 01, 2002 at 11:30:01PM +0100, Mirek Dobsicek wrote:
| First I've inslalled samba* and cups* debs to my woody box.
| I tried to share some folders with samba and it worked fine.
| well, my printer Epson LQ 100+ ESC/P2 is found on /dev/lp0

Is that a line printer or an inkjet?

| /usr/sbin/lpadmin -p EpsonLQ -E -v parallel:/dev/lp0 -m epson24.ppd

I think those epson drivers are for line printers, not inkjets.  

| whouu, it's printing, but the resolution is terrible.

If it's an inkjet, I'm not too surprised.  Did you install the
cupsys-driver-gimpprint and the cupsomatic-ppd packages?

| Wanted to edit some config, but I cant find any. Where are
| stored information about my printer??? Which file I have to edit?

Point a web browser at http://localhost:631/

The web interface is really convenient and it will list all the
available drivers.  Pick the one that is closest to your model.

| Finaly, on cups.org i find how to make cups and samba work together.
| I added this lines to my smb.conf
| printing = cups
| load printers = yes


| printcap name = cups

Is that where your printcap is?  Likely not.  Here's the relevant
portions of my smb.conf :

    printing = cups
    load printers = yes
; A "magic" section.
    comment = All Printers
    available = yes
    directory = /tmp
    printable = yes
    public = yes
    writable = yes
    create mode = 0666
    browseable = yes

    guest ok = yes
    guest account = nobody

The other day I noticed that with /etc/printcap non-existant, my
printers didn't exist.  I created the "bogus" printcap by modifying
the line in /etc/cups/cupsd.conf to be

Printcap /etc/printcap

and restarting cups.  The printcap for me looks like :


(that is, it is just a place holder for the names so that apps that
parse the the printcap to find printers will find the names.



THe lot is cast into the lap,
but its every decision is from the Lord.
        Proverbs 16:33

Reply to: