[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

compiling with the vpn patch



    Hey people. 

    I'm trying to patch kernel 2.2.18 and 2.2.20 with the vpn patch.
Unfortunately, it presents no new option for IPsec MASQ under a make
menuconfig. So, putting the following in manually

    CONFIG_IP_MASQUERADE_IPSEC=y

    I get compile errors

make[4]: Entering directory `/usr/src/kernel-source-2.2.18/net/ipv4'
cc -D__KERNEL__ -I/usr/src/kernel-source-2.2.18/include -Wall
-Wstrict-prototypes -O2 -fomit-frame-pointer -fno-strict-aliasing -pipe
-fno-strength-reduce -m486 -malign-loops=2 -malign-jumps=2 -malign-functions=2
-DCPU=686   -DEXPORT_SYMTAB -c ip_masq.c
ip_masq.c:391: `ip_masq_hash' undeclared here (not in a function)
ip_masq.c:391: initializer element is not constant
ip_masq.c:391: (near initialization for `__ksymtab_ip_masq_hash.value')
ip_masq.c:392: `ip_masq_unhash' undeclared here (not in a function)
ip_masq.c:392: initializer element is not constant
ip_masq.c:392: (near initialization for `__ksymtab_ip_masq_unhash.value')
ip_masq.c:334: warning: `masq_port_lock' defined but not used

    Help?

    Don't just tell me to use 2.4. I know that's an option already, but
currently I'd like to get this working with 2.2.

    Mike

-- 
Michael P. Soulier <msoulier@mcss.mcmaster.ca>, GnuPG pub key: 5BC8BE08
"...the word HACK is used as a verb to indicate a massive amount
of nerd-like effort."  -Harley Hahn, A Student's Guide to Unix

Attachment: pgpTAOdXA5Tsc.pgp
Description: PGP signature


Reply to: