[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installing Debian



Liam Black wrote:

(Kent writes: I'm CC:'ing this to the list for historical recording purposes, perhaps for the use of others in the future.)


Kent Said:
----
Oh, you've apparently already found this manual. Yet I'm confused.
Earlier you say you're booting from floppies, yet here you say you're
installing from a hard drive partition.

So perhaps you might want to provide more info. For example, what's on
/dev/hda and /dev/hdb? Are you wanting to keep that? Are you planning on
installing Debian on /dev/hdc, and how many partitions do you plan to
have for Debian? Is this going to be a multi-OS system? Do you
understand these types of questions?
----


Kent adds: I misspoke my last message; if you're installing from a DOS partition you don't need to mess with floppies, but if you're installing from an ext2 partition, apparently you do. More below.


Liam replies:
----

/dev/hda contains my linux swap (hda1) and primary boot (hda2) for my
Slackware installation (what I'm currently running at home). Debian struck
me as quite attractive and I wanted to replace Slackware with Debian.

I'm planning to install it onto /dev/hda, actually, after i re-partition it
(I don't like the order of boot and swap on it). I plan to have /dev/hda1:
Boot, /dev/hda2: Swap, /dev/hdc1:usr, /dev/hdc2:misc. (partition for me to
tool around in, will just mount it in /mnt)

It's only going to be a single-OS system (Linux). I understand these
questions okay. ;)


So I assume you've saved any data you want to keep, and we can just assume you're ready to wipe the first drive?


I understand the bad response thing. I've been at the fringes of Linux for
awhile, professionally I'm an analyst who occasionally interfaces with Unix
systems, so I know my way around command line, and occasionally poke about
on Slashdot (which is what taught me to expect the bad response)

Here is my understanding of the installation method:

1) Create Rescue Floppy
2) Copy base2_2.tgz to somewhere on your linux partition


I would recommend /dev/hdc2, so that during the installation you can format /dev/hdc1 and mount it as /usr.

3) copy drivers.tgz to somewhere on your linux partition


Ditto to #2.

-----------QUESTION: SHOULD I UNTAR THESE FILES?----------------------


No. The installer will do that for you.

4) shutdown -r now, floppy in drive
5) boot: prompt, hit <enter>
6) Your installation program should load and everything should go fine.


That's right; however, it seems to not be working for you. In addition, you've tried a lot of different options (below) which I might would've suggested.

So, here's my next suggestion. Move the two *.tgz files to /dev/hda1, just to see what happens. We'll have to do something different in order to get your partitions the way you want them, but the results of this test might give us a clue.

However, a gut instinct tells me that perhaps your rescue floppy is faulty. Back in the days when it was common to install the entire base system from floppy, you had to use 10 or 12 diskettes, and they had to be absolutely perfect. Even if they formatted without errors, sometimes they'd have an error which would bomb out during the installation. So you used a different floppy and recreated the image. (I've had to try up to 4 different floppies in the past to get one that worked.) I don't know if the rescue floppy is that picky, but it wouldn't take much effort to use a different *good* floppy and create a new image to try.

Another option, if you've got a copy of DR/MS-DOS floating around is to create a 10MB or so partition on hdc and put the *.tgz files there, and then to use a DOS boot floppy to boot into DOS, and use the LOADLIN.EXE program to start the installation.

Let us know how you go from here and what the results are, and we'll see how much farther down the road we can get.


However, I get:
Mounted filesystem (ext2fs) read-only. Kernel Panic. Cannot open initial
console. (this is a condensed version of the error messages)

So, from step 2-3 I've tried with untar and i've tried leaving them tarred.
No appreciable difference, except in the "This is an unconfigured" (covered
in my previous mail), and the need to chmod /dev/console on /dev/hdc1

Alternate processes from step 5 on:

rescue root=/dev/hdc1: Mounted filesystem (ext2fs) read-only. Kernel Panic.
Cannot open initial console.
linux  root=/dev/hdc1: Mounted filesystem (ext2fs) read-only. Kernel Panic.
Cannot open initial console.
rescue root=/dev/hda2: Mounted filesystem. Etc. Boots my Slackware System
just fine. ;)
rescue root=/dev/hdc1 init=install.sh: Mounted filesystem (ext2fs)
read-only. Kernel Panic. Cannot open initial console.
rescue root=/dev/hdc1 init=/dev/fd0/install.sh Mounted filesystem (ext2fs)
read-only. Kernel Panic. Cannot open initial console. (wasn't expecting
this one to work but i thought I'd try it)

Nothing seems to have much effect... I think I'm just a complete moron and
left out a little step or didn't make an assumption that I was supposed to.


No, I don't think you're a moron; something seems to be wrong. But I'm confident that we'll be able to beat the thing into submission.


Thanks much,
Liam

P.S. If Lotus Notes is inserting any HTML stuff, please let me know. I have
it disabled, but it looks a bit funny in my display window nonetheless.



Looks okay on this end, both in Mutt and in Mozilla Mail.


Kent



Reply to: