[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Newbie comments & queries



on Sun, Dec 02, 2001 at 05:49:21PM +0200, Ian Balchin (fables@imaginet.co.za) wrote:

> We came to a grinding halt long before consideration of the packages about 
> which you wish to differ.
> 
> I installed via tasksel the 'Dial Up' packages.
> 
> All went well until wvdialconf had its turn. No modem detected, so
> after 3 tries I left it until later.

Modems can be persnickety.  I've got one that likes having the box shut
down, case removed, and modem card jiggled, before it will restart
cleanly.  Power down alone isn't enough.

> Facts:
> 
>   - Microcom Deskporte 28.8P modem was working minutes before I took it
>     into my hot waiting hands.
>   - The modem is switched on.
>   - The correct light (HS) is on after switchon and initialisation
>   - The modem is connected to the serial port
>   - The serial port is connected to the board and in dos msd reports OK

Sounds like (below) you've got two systems, one running DOS.  Can you
access the modem from DOS?

>   - The phone line is plugged in
> 
> Action am running the command line:
> 
>     $wvdialconf /etc/wvdialconf
> 
>     "Sorry, no modem detected. Is it in use by another programme?"
>     "Did you configure it properly with setserial?"

I haven't used wvdialconf (and am currently using an OpenBSD box for
dialout).  IIRC you may want to use pppconf to configure your modem.

> ditto with more info re AT commands reporting 'nothing' if run at root #
> 
> noted at installation maybe need to run setserial, so
> 
>     #setserial /dev/ttyS0
>     reports 0x3f8 irq4 and seems ok
> 
>     #setserial /dev/ttyS1
>     reports 0x2f8 irq3 and seems OK
> 
> .. so no irq conflict.  Also these settings appear on the screen at
> bootup time

Check your 'dmesg' (or /var/log/dmesg) output.  Should be something
like:

    Detected PS/2 Mouse Port.
    Serial driver version 4.27 with no serial options enabled
    ttyS00 at 0x03f8 (irq = 4) is a 16550A
    ttyS01 at 0x02f8 (irq = 3) is a 16550A
    ttyS02 at 0x03e8 (irq = 4) is a 16550A
    pty: 512 Unix98 ptys configured
    Real Time Clock Driver v1.09

>   - Looked in BIOS and tried settings for onboard serial ports other than
>     standard with no success.

Hmm...Maybe you want to describe your BIOS and optional settings in more
detail.  I've seen BIOSes that let the OS mediate ports.  This is *not*
what you want, you want to use the BIOS settings.

>   - Plugged in another serial port connector to the board, no success
> 
>   - Tried on S0 (Com1) with no success except different set of lights
>     on modem after intialisation (The one HS light on with S1 is
>     apparently correct)
> 
>   - I turned the cable connector around on the board, no success.
> 
>   - There is no /dev/modem

This is just a symbolic link to the ttyS* file that your modem is
physically connected to, and a convention, not a necessity.

>   - I accessed the FAQ at www.worldvision.ca/wvdial  but nothing of
>     any help there.
> 
>   - Also, the modem is one of those that would connect via a parallel
>     port.  Any ideas how to do that?

*Parallel* port?  Not a serial port?  Not sure I've seen one of them.

/dev/ttyS[012] almost certainly isn't going to be the device file you
want though.

> Could this be something with the serial port settings?  If I run set
> serial with no switches or device, the info runs off the top of the
> screen and it cannot be piped thru 'less' or 'lpr'. Dos msd shows for
> S0 (COM2) at 2400 baud
> 
> Now I am getting desperate, clutching at straws.
> 
> 
> 
> A couple of other small frustrations.
> 
> The up and down arrows on the keyboard recall previous commands at the
> prompt.  Trouble is, the latest ones, as used above, do not survive a
> reboot, recalling only older commands. (Used to, I am sure, or where
> does it get all my old ls commands from now?)

Your history file ~/.bash_history is only written when a shell exits
normally.  If you're crashing your shell, it may not be saved.

> How do I ensure that it hephaustus (my machine)boots up with Numlock on?

This is a BIOS setting.



> My modemless friend on her way to Florida donated her cat to me.  I must
> remember to borrow the vets thick leather gloves on Monday ..... It
> hisses everytime I go near it. My male mog stared at it and just walked
> off, probably thinking that she is menopausal (male chauvinistic pig
> that he is).

"Mog"?  Or is that "dog"?

Cat are very territorial and don't like new settings (and/or people
and/or animals).  You'll probably find she likes hiding in some
sheltered area -- under furniture, beds, or buried in a closet are
favorites.  A cozy box (old towel or similar) near food, out of main
traffic paths, but capable of observing what's going on, may be
welcomed.

Is this a permanent donation?

Peace.

-- 
Karsten M. Self <kmself@ix.netcom.com>       http://kmself.home.netcom.com/
 What part of "Gestalt" don't you understand?             Home of the brave
  http://gestalt-system.sourceforge.net/                   Land of the free
   Free Dmitry! Boycott Adobe! Repeal the DMCA! http://www.freesklyarov.org
Geek for Hire                     http://kmself.home.netcom.com/resume.html

Attachment: pgpVFYlZcHvQo.pgp
Description: PGP signature


Reply to: