[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problems creating a boot floppy


I've been having problems booting Debian from floppy. 

The reason I boot from floppy is that I have 2 hard disks on my PC:
Windows lives on the first, and linux on the second, with my root 
partition on  /dev/sdb1. 

I installed Debian from CD, and this created a boot floppy
pretty straightforwardly, which has always worked. However, 
I'd like to recompile the kernel and install it on a new

Configuration (xconfig) and compilation--I use the commands: 
make dep,   make clean, make bzImage (or bzdisk)---seem to go
fine, and I install the new lean 'n' mean kernel on an 
unformatted floppy either manually (using dd) or via  make bzdisk 
(either seems to do exactly the same thing).

Anyway, I then reboot, and consistently get the following kernel 
  request_module[block-major-8]: Root fs not mounted
  VFS: Cannot open root device 08:11
  Kernel panic: VFS: Unable to mount root fs on 08:11

I have checked the kernel image with 
rdev  and it comes back with  /dev/sdb1  as required. A  rdev -R
command gives me  1, which is (I believe) correct (in any case, I've 
tested setting the rootflag to 0 and I have the same problem).

The one thing that's really odd (to me at least!) about the above 
kernel panic is that an ls -als in  /dev  shows me that the 
major:minor number for /dev/sdb1 is  08:17  and not  08:11. I 
decided that this *might* be connected with the slight (apparent) 
anomaly on the  rdev  man page, namely that the root device parameters
                 which is at odds with the numbers [1-16] in /dev (and in 
/usr/src/linux/Documentation/devices.txt). Anyway....I tried setting 
the root device in the kernel image to  /dev/sdb7  (which doesn't exist)
and got back the very same message except that it now referred not to
08:11 but to 08:17...supposedly the correct major:minor number for 

So, now I'm really stumped! I ought to point out that I've compiled floppy
support, ext2 support and ramdisk support into the kernel image (also
msdos, fat, vfat and umsdos!), and I can't think what else I might 
have missed out. My best guess is still that it's to do with linux
living on the second disk, but that's as far as I've got.

Most recently I've decided that I may have to create a boot floppy in 
a similar way to the original installation floppy (the Debian way!),
but I've no idea how to do that!

Any help on how to create a boot floppy in these circumstances--either 
what I've done wrong so far, or on a different way of creating a boot
floppy--- would be gratefully received!





 Dr. Nick Dodd               
 University of Nottingham
 Division of Environmental Fluid Mechanics
 School of Civil Engineering
 Nottingham, NG7 2RD      Tel: +44-(0)115-951-4164 (Direct)
 England                       +44-(0)115-951-3904 (Sec.)
                          Fax: +44-(0)115-951-3898
 Email: nick.dodd@nottingham.ac.uk

   "...I'll be standing on the beach with my guitar"
   --Radiohead: "Anyone Can Play Guitar"


Reply to: