[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

HP DeskJet 632C - can't print



Ever since I've been a system administrator, I've hated printing
under UNIX. Some things will probably never change.

I have a new 632C, and I can't get anything to work. I have
investigated the hpijs driver; it seems to be integrated into gs
(probably violating HP's non-free license, but that's a topic for
a different list), but no luck. I added the appropriate printer
description into lprngtool's database, configured a printer via
that tool, and put the hpijs binary in /usr/bin; still no luck.

I tried running gs manually:
> gs -sDeviceName=DJ6xxPhoto -sDEVICE=hpijs ~/input.ps > /tmp/pcl
GNU Ghostscript 6.51: Unrecoverable error, exit code 1

When I strace the running lpd (I have the latest lprng package),
I don't see gs exec'd.

I freely admit, I'm an idiot when it comes to all aspects of
printing. If there's anyone who has gotten hpijs to work, or
gotten any recent HP DeskJet model working, I'd appreciate any
advice.

-John Daily
john@geekhavoc.com








Reply to: