[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Can't get java working with Airport Configurator

I am trying to configure my Appe Airport Basestation using the Java
Configurator.  It requires Java 1.2 but apparently can work with some an
extra download (swing library for java < 1.2).  I am a java newbie and
have never had any success trying to execute java apps :(

Apparently the command to run the app is "java -jar
AirportConfigurator.jar" but I can't get it to work.  I'm pretty sure I
haven't got java installed properly.  I've tried installing jdk1.1.  It
installs a binary called java but it doesn't have the -jar command line
switch.  Maybe the extra swing library download has this ???  I've also
tried installing kaffe which does support the -jar switch.

$ kaffe AirportBaseStationConfig.jar
java.lang.NoClassDefFoundError: AirportBaseStationConfig/jar
 at java.lang.Throwable.<init>(Throwable.java:38)
 at java.lang.Error.<init>(Error.java:21)
 at java.lang.LinkageError.<init>(LinkageError.java:21)
 at java.lang.NoClassDefFoundError.<init>(NoClassDefFoundError.java:21)

$ kaffe -classpath . -jar AirportBaseStationConfig.jar
Couldn't find or load essential class `java/lang/Object'
java.lang.NoClassDefFoundError java/lang/Object

How do I successfully install a Java 1.2 Runtime Environment ? (using
apt preferably).  I can't find any 1.2 JRE's using "apt-cache search"
and "apt-cache show".

Please help.  I appreciate any comments, suggestions and pointers.
Brendan Simon.

Reply to: