[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: problem with printing win2k to samba/cups

On Sunday 07 October 2001 03:21 pm, Ron Farrer wrote:
> Hello,
> I'm trying to get a win2k pro system to print to my testing/unstable
> system. Printing works great on the Linux box, but printing from the
> win2k box results in nothing happinging. I'm using the native win2k
> print driver for the printer (which I would like to get working). This
> is in the CUPS error log: E [03/Oct/2001:10:28:58 -0800] print_job:
> Unsupported format 'application/octet-stream'!
> I tried adding this line to my PPD:
> *cupsFilter:    "application/octet-stream 100 rastertoprinter"

I didn't have to do that.  Instead, I have the following my smb.conf file:
        ; The following three lines will allow the available
        ; printers to be slurped from lpstat.

        printing = CUPS
        printcap name = lpstat
        load printers = yes

        comment = All Printers
        path = /tmp
        browseable = no
        public = yes
        writable = no
        printable = yes
        create mode = 0700

        ; The raw option allows printing from Windows using the
        ; driver provided by Epson.
        ; The gs-stp package and a cups-o-matic driver
        ; for the Epson Stylus 740 are used for local printing.

        print command = /usr/bin/lpr -P %p -o raw %s
        lpq command = /usr/bin/lpstat -o %p
        lprm command = /usr/bin/cancel %p-%j
        available = yes

> But it still gives the same error... Can someone explain how to get this
> to work correctly?
> TIA!
> Ron

Reply to: