[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: CDROM problems with installer 2.2.23

On Monday 17 September 2001 08:19 pm, richard wrote:
> Hi
> Have installed potato(carefully,multiple times) using boot floppy images
> 2.2.23 from CDROM. On reboot, apt-get tries to access packages and gets
> error: "fs iso9660 not supported by kernel". Using mount has always
> given the same error. I tried using an older version installer (2.1)

Sounds like you don't have support in your kernel for ISO 9660 file systems.  
Which floppy images did you use?  I'd imagine they'd all at least have 
support for ISO 9660.

If you're getting an fs error then it's likely your drive was detected but 
the kernel can't read the media.  You could check your kernel logs (dmesg) to 
see if your CD-ROM is detected, but I suspect it has been.

Usually your recourse is to recompile the kernel with support for ISO 9660 
file system, but if you're using the stock kernel from the installation disks 
then the fact that it can't read the CD is strange indeed.

> which explicitly refused to load the cdrom module. The CDROM is ATAPI,
> ASUS CD S400/A and should not need a special driver. The computer is AMD
> K5 -- Debian is hdc secondary master, CDROM is hdd secondary slave.
> CDROM  works fine on Mandrake 8.0 which is on a different physical drive
> hda, dual boot using LILO. CDROM works on floppy or CDROM Debian boot
> media, just not from Debian on hdc. I tried to use ftp for access
> thinking to try to compile a different kernel but on the last two tries
> apt-get now cannot name resolve the Debian ftp site. I had gotten
> further with this Debian install and after some effort X-windows was
> working somewhat. I then tried to mess with kernel issues to get the
> CDROM working but I'm not winning.
> As I reread this, sounds like hdc maybe can't reach the CDROM. I'll
> check the hardware, but are there any other insights?
> Richard

Reply to: