[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installed Woody Package, Killed X

--- Robert Mosher <mosher@andrews.edu> (2001-09-13 00:30):
> I added the testing sources to my sources.list in order to get a few 
> packages in woody (mainly vlc-gtk), and in doing so upgrade some X 
> related packages. Now when I run 'startx' I get this error:
> 	X: cannot stat /etc/X11/X (No such file or directory), aborting.
> I got some help in #debian, where it was suggested I create a link to 
> /usr/bin/X11/X in /etc/X11. I did that, but then got this error:
> 	X: /etc/X11/X points back to X wrapper executable, aborting.
> I also tried copying /usr/bin/X11/X to /etc/X11, but that gave me this error:
> 	X: cannot read /etc/X11/X symbolic link (Invalid argument), aborting.

What you need to do is link /etc/X11/X to /usr/bin/X11/XFree86.  You
can do so with the following command (as root):

ln -s /etc/X11/X /usr/bin/X11/XFree86

That should fix the problem (no deinstalling of packages necessary).


Sean Quinlan (smq@gmx.co.uk)

Reply to: