[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Woody: problems upgrading lately?

%% Bill Wohler <wohler@newt.com> writes:

  bw> No problems here. If you already have a woody system, you don't
  bw> need apt-get dist-upgrade. Just apt-get upgrade.

Neither them work.  Sorry, I should have said that.

Since I've updated last, now if I try "apt-get upgrade" I get:

  # apt-get -s --ignore-hold upgrade
  Reading Package Lists... Done
  Building Dependency Tree... Done
  The following packages have been kept back
    cygnus-stylesheets debian-policy expect5.24 gsfonts gsfonts-x11
  213 packages upgraded, 0 newly installed, 0 to remove and 6  not upgraded.
  Sorry, but the following packages have unmet dependencies:
    am-utils:  dpkg-perl: Depends: perl5
               Depends: libnet-perl but 1.0703-4.1 is to be installed
    libgtk-perl: Depends: libgtk1.2 (>= 1.2.0) but 1.2.10-1 is to be installed
                 Conflicts: libgtk-imlib-perl (< 0.7000) but it is not going to be installed
    mesag3+ggi: Depends: libggi2 (> 1: but 1: is to be installed
                Depends: xlib6g (>= 3.3.6-4) but 4.0.3-4 is to be installed
                Conflicts: libgl1
    pspell-ispell: Depends: libstdc++2.10 but 1:2.95.2-14 is to be installed
    task-c-dev: Depends: task-devel-common but 0.7 is to be installed
  E: Internal Error, InstallPackages was called with broken packages!

I don't really understand some of these messages; for example
libgtk-perl says it depends on libgtk1.2 >= 1.2.0 but 1.2.10-1 is to be
installed... well, 1.2.10-1 _is_ >= 1.2.0, isn't it?

Is that last line normal in this situation, or does it mean that
something more sinister is going on?

If I try "apt-get dist-upgrade" now it doesn't fail, but:

  # apt-get --ignore-hold dist-upgrade
  Reading Package Lists... Done
  Building Dependency Tree... Done
  Calculating Upgrade... Done
  The following packages will be REMOVED:
    am-utils dpkg-perl glutg3 gnome-control-center gs-aladdin gv kdebase-crypto
    kdebase-libs kdelibs3 kdelibs3-crypto konqueror libgtk-perl libkonq3 libqt2
    libxml-dom-perl mesag3+ggi mysql-navigator pdl pspell-ispell pstoedit
    ssystem task-c-dev task-gnome-apps task-gnome-desktop task-tex
    task-x-window-system-core xbase-clients xf86setup xscreensaver-gl 
  The following NEW packages will be installed:
    defoma dialog expect libxml-enno-perl 
  The following packages have been kept back
    cygnus-stylesheets debian-policy 
  214 packages upgraded, 4 newly installed, 29 to remove and 2  not upgraded.

Well, some of those I don't care about, like konqueror (I just wanted to
try it out).  But I can't lose am-utils, that's critical to my system!
Likewise gv, pspell-ispell, and a few others.

What's going on here?

 Paul D. Smith <pausmith@nortelnetworks.com> HASMAT--HA Software Mthds & Tools
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
   These are my opinions---Nortel Networks takes no responsibility for them.

Reply to: