[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

3Com 3c900 Boomerang 10Mbps Combo problem

Are there any people out there able/willing to help me with this?

I'm having some trouble with my 3Com 3c900 Boomerang 10Mbps Combo Ethernet
card under Linux 2.2 (Debian potato). In the machine I've also got another
ethernetcard (DLink). The mqachine acts as a gateway and the DLink card is
connected to my DSL-modem and the 3Com card is connected by a crossedTP to
my other computer (Win98 machine).

The problems are:

When I try to connect the 3com card to the DSL-modem I can't get a IP by
DHCP. The machine just sits there and times out after a while (I've tried
it _several_ times). Using the DLink card to get an IP is never a
problem. Not even having the 3Com card in the win98-machine connected
directly to the DSL-modem is causing any trouble. 

If I have both machines switched off and boot up the Linux-machine and
then the win98-machine I'm unable to get any contact between the two (I
have to "ifconfig eth1 down ; ifconfig eth1 up" to get contact).
If I boot up the win98-machine first and then the Linux machine I get

I get alot of collisions. Check this out:

eth0      Link encap:Ethernet  HWaddr 00:05:5D:F5:33:B7
          inet addr:  Bcast:  Mask:
          UP BROADCAST RUNNING  MTU:1500  Metric:1
          RX packets:46875 errors:0 dropped:0 overruns:0 frame:0
          TX packets:33403 errors:0 dropped:0 overruns:0 carrier:0
          collisions:8 txqueuelen:100
          Interrupt:9 Base address:0xdc00

eth1      Link encap:Ethernet  HWaddr 00:60:97:60:E7:8B
          inet addr:  Bcast:  Mask:
          RX packets:353729 errors:0 dropped:0 overruns:0 frame:0
          TX packets:636359 errors:0 dropped:0 overruns:0 carrier:0
          collisions:241617 txqueuelen:100
          Interrupt:10 Base address:0xdf00

eth0 is the Dlink card connected to the DSL-modem.
eth1 is the 3Com card connected to the win98 machine.

The speed (between Linux and win98) is is not too bad though
(1000kb/s) (FTP)

I've tried changing the 3Com cards settings (Mediatype/Duplex etc.) with
the 3Com DOS-utitily without any improvements.


Reply to: