[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Broken packages


I've been trying to install the libglib1.2-dev package
and it recommends libgtk-doc. I already have libglib

Now when I ask the above to be installed, the
post-installation script fails with a "could not lock
dir for editing" message and my packages are
half-configured. If I then try to remove either of the
packages, I get the same message that it couldn't lock
to the dir and no such dir,etc.

I can't just configure the packages since it says that
the directory doesn't exist.

I've tried using a --force-reinstreq --remove but that
has the same fate.

I've tried manually editing the /var/lib/dpkg/status
file so that the package status is as though the
package isn't installed i.e. purge ok not-installed in
the status field....however next time I try
installing, it has the same fate.

I've tried downloading a new libglib1.2-dev package
from the web....no effect.

I've tried just unpacking the files...this happens
ok...however if i try configuring them it says the it
can't lock dir for editing.

I'm root on my system and I've also tried updatedb
after installing or trying to remove etc....have also
tried Dselect and then update.

I can't use GTK on my system....i really need help
ppl....i don't know what to do.

Hoping someone will help me.

Do You Yahoo!?
Make international calls for as low as $.04/minute with Yahoo! Messenger

Reply to: