[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Network Drivers

Andy Laurence wrote:
> > > OK, I've managed to get the default drivers installed
> > (driver-1.bin), but
> > > there is no 82559 driver
> >
> > No.  It is the eepro100 driver, as Slaven Peles mentioned.
> I've tried that one ...
> ----------
> /lib/modules/2.2.19pre17-idepci/net/eepro.o: init_module: Device or resource
> busy
> Hint: this error can be caused by incorrect module parameters, including
> invalid IO or IRQ parameters
> /lib/.../eepro.o: insmod /lib/.../eepro.o failed
> /lib/.../eepro.o: insmod eepro failed
> Installation failed
Nope, not eepro, eepro100.

Write back when you've tried to load that one.

Sometimes, you need to load the pci-scan module first.

I've got one here built for 2.2.15; I guess it will work on 2.2.19:


For further reference, see:


(I had a Linksys card (tulip driver) that wouldn't work without pci-scan
under 2.2.15.  I happened to build the tulip driver into my 2.2.19
kernel, and it didn't need pci-scan after that.  Whether this is because
the tulip driver was updated under 2.2.19, because I'm not using tulip
as a separate module anymore, or some other reason, I don't know).

Reply to: