[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: How to startx as normal user?

On Thu, Aug 02, 2001 at 01:15:53AM -0700, Brad Rhodes wrote:
> In /etc/, 'ls X*' lists xserver, a directory, and Xserver, a regular file. 'ls
> x*' yields 'ls: x*: No such file or directory' although there are several files
> starting with a lowercase x (???). I tried 'less' on Xserver, to look at it, but
> it says 'Xserver: No such file or directory' (???). I tried to cd into xserver,
> but it says '/etc/xserver: No such file or directory' (???). Both files have
> read permissions set for owner, group, and other users, and I was logged in as
> root. I don't understand what's going on.

You're probably getting confused because /etc/X* is expanded by the
shell to /etc/X11/ (the only X<foo> in /etc/ that I know of).  Remember,
unquoted wildcards on the command line are interpreted by the shell for
file globs.

$ ls /etc/x*

config  database/  entries/  scripts/  sound/


Eric G. Miller <egm2@jps.net>

Reply to: