[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

XFree86 4.1 woes, part2

...me again !

As I mentionned 2 days ago, I'm unable to upgrade X 4.0x to X 4.1.0
because of a dpkg error that I'll reproduce again here :

/var/lib/dpkg/info/xserver-xfree86.config: return: bad non-numeric arg `Check'
dpkg: error processing xserver-xfree86 (--configure): subprocess post-installation script returned error exit status 128
Errors were encountered while processing: xserver-xfree86
E: Sub-process /usr/bin/dpkg returned an error code (1)

Since I hadn't gotten an answer on that problem here, I decided to risk it
all and try apt-get remove xserver-xfree86, purging all config files and
then try reinstalling and reconfiguring from scratch.

This time here's what I get :

dexconf : cannot generate configuration file;
xserver-xfree86/config/device/use_fbdev not set. Aborting. Reconfigure the X server with "dpkg-reconfigure" to correct this problem.
Unable to write X server configuration file.

Now what ? I've did as I was told, tried dpkg-reconfigure, and throws the
same error at me. What is going on, any ideas ? Now I'm afraid of shutting
down that machine, since for now it keeps running an X Server and don't
want to lose it until I can get a replacement X server...

Many thanks, I'm getting a bit anxious and desesperate.


Reply to: