[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Safe File Manager to run as root ?

On Wed, Jul 18, 2001 at 02:22:30PM -0400, Hall Stevenson wrote:
| > I've never used mc, but I did try gmc a while back.  I
| > stopped using gmc when I tried to _copy_ some files
| > from a floppy.  Instead the default drag-n-drop action
| > is move.
| From being a fairly experienced windows user, and apparently
| one of the few who understand and use drag-n-drop (I've seen
| very few people who actually do it...), I have a pretty good
| grasp on the situation. It appears that the gmc developers
| either copied Windows Explorer behavior, or Explorer is
| copying something before it. I don't know, nor care. I've used
| Sun's file manager from Open Windows on the Sparcs we used to
| use at work, but don't recall it's behavior. Anyone ??

I used/use explorer a lot in windows (actually less now with a good
cygwin install).

| Here it goes:
| * If you drag a file from one *drive* to another, the default
| is to *copy*
| * If you drag a file from one directory to another directory,
| the default is to *move*
That sounds about right (for windows anyways).

| Since the *nix world makes everything a dir, you're going to
| move a file instead of copy it. Going from a floppy to your
| hard drive follows the two drives logic.

Yeah, it would be "just" a dir.
| By the way, in both Windows and gmc, dragging with the right
| button in Windows and the middle button in gmc prompts you as
| to what you want to do. The choices are move, copy, and
| link/shortcut. I actually do it this way all the time... A
| good habit, I think.

I do that a lot when I'm in windows, I don't remember if I tried it in
gmc or not.

The _real_ problem wasn't the "default was move" situation, but rather
that it removed the originals even though there was an error and the
new ones couldn't be created.  That left me without _any_ copy of the
files.  It should have stopped, and left the originals alone, when it
found out the destination files couldn't be created.  This is what
'mv' does.


Reply to: