[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: GRUB & Rieserfs

D-Man wrote:

> | Well... it does... I did set up a symbolic link to .  (boot -> .)
> | I've also tried doing
> | root (hd0,0)
> | kernel /vmliuz-2.4.5 root=/dev/hda3 single
> Hmm.
> |
> | I could use some clarification on this one point:
> | Under GRUB 'root"  (as in root (hd0,0)) means exactly what?
> | I am assuming it DOES NOT mean what drive is going to endup being / (root)
> | once the OS is running but rather the root of all GRUB operations.  Is this
> | true?
> I think this is a good explanation.  The "root=" argument to the
> kernel specifies the root directory once the kernel (OS) is running.
> | What is the significant difference between:
> | root (hd0,0)
> | kernel /vmlinuz-2.4.5 root=/dev/hda3 single
> |
> | and:
> | root (hd0,2)
> | kernel (hd0,0)/vmlinuz-2.4.5 root=/dev/hda3 single
> The difference is that in the first one you are implying that '/' is
> (hd0,0) because of the "root" line.  In the second one you are
> explictly stating which drive to use as the root of that path.
> What does the "single" argument to the kernel mean?  (check Linux
> docs, not grub).  I am not familiar with it and that may be causing
> the problem.

the `single` argument on the kernel command line stops the boot process
before  it goes into multi-user mode (you get the prompt to enter the root
password or type Ctrl-D to continue booting).

> Just to start over, and since I didn't pay much attention to the
> beginning of the thread, where does the booting fail and what message
> do you get?  Does grub manage to load the menu.lst file?  Did you
> include Resierfs support in the kernel, not as a module?

Ok.  There's been a lot of suggestions and I've tried many things.
I can get the GRUB menu to come up - no problem.
I can get the system to boot my 2.4.5 kernel - no problem.
I can get the 2.4.5 kernel to mount ext2 FS as root - no problem.
Once I have an ext2 root I can mount a reiserfs partition - no problem.
I've double checked that reiserfs support is built into the kernel and not
as a module.
I can get the kernel to boot and mount the reiserfs as root but it generates
a kernel panic as it can't find `init` - BIG PROBLEM.

Now, I know that there is an /sbin/init on the reiserfs.  Here's how I've
I've mounted the FS and physically looked.
I've been in the GRUB command line and run `find /sbin/init` and it's returned
every drive that I'd expect it to return.  (With some exceptions I'll go into
in a minute...)

Does GRUB support reiserfs?  The answer seems to be "Yes!"
Does the kernel have reiserfs support built-in?  Appears to also be "yes".
Is GRUB installed correctly?  I NOW NOT SO SURE.  I do get a GRUB
menu.  But... when I drop out to the GRUB command line I don't think
it's reading my device.map file... though the partitions I'm working with
are all on /dev/hda (which GRUB correctly sees as (hd0)).
Does GRUB load the kernel? Yes.
Does the kernel load the reiserfs FS as root?  yes.
Does the kernel find `init` and continue booting?  NO!


> HTH,
> -D

Reply to: