[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

X server with ASUS all in one motherboard with SiS 630E chipset

Hi Kent, thanks for your effort.

> As far as sound goes you need to add support for your kernel to
do that.
> The LAN card will need a module installed.  I looked at -
> http://www.uni-paderborn.de/Linux/mdw/HOWTO/Hardware-HOWTO.html
> and didn't see an SiS LAN or sound card listed.  You might want
to post
> a separate tread on that topic.


> > > As to your second question what video card are you using?
> >
> > I have used ASUS's CUSI-M with SiS 630E chipset (all in one
> > board) on board VGA card with SiS 300 integrates a 2xAGP
> > on board LAN card with SiS 7016/7014 (10/100Mb) ethernet
> > on board SOUND card with Cmedia CMI 8738/PCI audio controller
> >
> OK if your using an SiS card you should more than likely
> xserver-sis
> # apt-get install xserver-sis
> Then run XF86Setup and pick your SiS card.  Backup you
> /etc/X11/XF86Config file first though so you can fall back on
your old
> config if the new one fails.  You say you have X working but I
think it
> would run a little nicer for you if you used the SiS driver.
Worth a
> try anyway.

I have tried to look my cd (Debian 2.2r0) but I cannot find
I am sure it is stored in Debian web site. Could you tell me how
download this driver through windows.
(I use Windows 2000 to connect to internet via LAN in office)

By the way, I have another question to ask:
Can more than one device share with one IRQ?

1. I have found my on board LAN adapter details (in Windows
Device Manager):
SiS 900 PCI Fast Ethernet Adapter
I/O: D400-D4FF, IRQ: 9

2. And on board SOUND adapter
C-Media CM8738 Audio
I/O: 9800-98FF, IRQ: 9, PCI Bus 0

3. MPU-401 Compatible MIDI Device
I/O: 0330-0331, IRQ: 9, on C-Media CM8738 Audio

I tried to change LAN adapter's IRQ from 9 to 11, but windows did
allow me to change to any IRQ. Well, it is another story.

> > Last night I "dpkg" xserver-svga driver, and then run
XF86Setup, and
> > eventually I got my X server running on 1024x768 mode. It
> > ok apart from on board SOUND card does not work and LAN card
> > have not tested yet.
> >
> > But this morning I turned on computer, it automatically used
xdm to start
> > X windows system (and with runlevel 2, I read some book -
runlevel must
> > set to 5 for using xdm). Furthermore, mouse did not work
> > (X windows system was still working).
> # apt-get remove xdm

I did that. But after I reboot Debian and type
# startx
X server looks ok apart from the PS/2 mouse pointer does not
So, I just use keyboard to test some programs which all work

Therefore, I ran XF86Setup again. After I selected PS/2 mouse,
pressed "apply", mouse pointer still stayed  where it was. Then I
selected any other mouse (not PS/2 of course), then key "apply".
After I have done this, I selected PS/2 mouse again, then it
It would not work if I restart x server.

I have tried several times, the results were the same.


Stephen Jiang   <stephenjiang@ieee.org>

Reply to: