[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Package installation error -- What is going on?



When I recently tried out aptitude, apt-get replaced apt 0.3.19 with apt
0.5.3.  On the very next install (docbook-doc), I had problems.  I don't
know if it was a problem with the docbook-doc package or of the new apt
package.  In the meanwhile, I'm afraid of installing more packages lest
I compound some problem with the package maintenance system.

I'm using unstable, as somewhere alone the line I needed something that
was unavailable in stable or testing.

Should I ignore this error and proceed as normal, or are there steps I
need to take to correct a problem?

(Please CC: me with any responses, as I no longer monitor the debian-user
list.  Thank you.)

Here is what happened:

  root:~ <pts/15> # apt-get -u install aptitude
  Reading Package Lists... Done
  Building Dependency Tree... Done
  The following extra packages will be installed:
    apt libsigc++0 
  The following NEW packages will be installed:
    aptitude libsigc++0 
  The following packages will be upgraded
    apt 
  1 packages upgraded, 2 newly installed, 0 to remove and 252 not upgraded.
  Need to get 579kB/1169kB of archives. After unpacking 2280kB will be used.
  Do you want to continue? [Y/n] 
  Get:1 http://http.us.debian.org unstable/main aptitude 0.2.2-1 [551kB]
  Get:2 http://http.us.debian.org unstable/main libsigc++0 1.0.3-2 [27.3kB]      
  Fetched 579kB in 20s (27.8kB/s)                                                
  (Reading database ... 29257 files and directories currently installed.)
  Preparing to replace apt 0.3.19 (using .../archives/apt_0.5.3_i386.deb) ...
  Unpacking replacement apt ...
  dpkg: warning - unable to delete old file `/var/state/apt/lists/partial': Direct
  ory not empty
  dpkg: warning - unable to delete old file `/var/state/apt/lists': Directory not 
  empty
  Setting up apt (0.5.3) ...

  Selecting previously deselected package libsigc++0.
  (Reading database ... 29268 files and directories currently installed.)
  Unpacking libsigc++0 (from .../libsigc++0_1.0.3-2_i386.deb) ...
  Selecting previously deselected package aptitude.
  Unpacking aptitude (from .../aptitude_0.2.2-1_i386.deb) ...
  Setting up libsigc++0 (1.0.3-2) ...

  Setting up aptitude (0.2.2-1) ...
  root:~ <pts/15> # 
  root:~ <pts/15> # aptitude 
  root:~ <pts/15> # apt-get -u install docbook-doc
  Reading Package Lists... Done
  Building Dependency Tree... Done
  The following NEW packages will be installed:
    docbook-doc 
  0 packages upgraded, 1 newly installed, 0 to remove and 252  not upgraded.
  Need to get 775kB of archives. After unpacking 4371kB will be used.
  Get:1 http://http.us.debian.org unstable/main docbook-doc 30d10-5 [775kB]
  Fetched 775kB in 25s (30.3kB/s)                                                               
  debconf: Perl may be unconfigured (Can't modify goto in lvalue subroutine return at /usr/share/
  perl5/Debconf/Base.pm line 24, near "}"
  Compilation failed in require at (eval 4) line 3.
	  ...propagated at /usr/share/perl/5.6.1/base.pm line 18.
  BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Iterator.pm line 5.
  Compilation failed in require at /usr/share/perl5/Debconf/Question.pm line 7.
  BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Question.pm line 7.
  Compilation failed in require at /usr/share/perl5/Debconf/Config.pm line 5.
  BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Config.pm line 5.
  Compilation failed in require at /usr/share/perl5/Debconf/Log.pm line 8.
  Compilation failed in require at (eval 1) line 4.
  BEGIN failed--compilation aborted at (eval 1) line 4.
  ) -- aborting
  Selecting previously deselected package docbook-doc.
  (Reading database ... 29313 files and directories currently installed.)
  Unpacking docbook-doc (from .../docbook-doc_30d10-5_all.deb) ...
  Setting up docbook-doc (30d10-5) ...

  root:~ <pts/15> # 




Reply to: