[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dselect, can't do update

Daniel Wagner <e9925791@student.tuwien.ac.at> wrote:
>since yesterday i've a strange problem with dselect. i tried to look
>for new packages at the mirror ( i use sid ), and did a update in
>dselect, everything seemed to work, but at the end of operation the
>following errormessage came.
>|Reading Package Lists... Done
>|Building Dependency Tree... Done
>|Merging Available information
>|Replacing available packages info, using /var/cache/apt/available.
>|dpkg: parse error, in file `/var/cache/apt/available' near line 1020
>package `blt':
>| `Replaces' field, reference to `blt-dev': error in version: version
>string has embedded spaces
>|update available list script returned error exit status 2.
>|Press <enter> to continue.

dpkg changed somewhat in version 1.9.8. I've been told that replacing
/usr/lib/dpkg/methods/apt/update with the contents of
http://people.debian.org/~bod/update helps with this.

Colin Watson                                     [cjw44@flatline.org.uk]

Reply to: