[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: "The following packages have been kept back"

On Sun, May 27, 2001 at 06:53:16PM +0300, matlads@techmuk.ac.ug wrote:
> Sorry, but the following packages have unmet dependencies:
>   aalib1: Depends: libc6 (>= 2.2.2-2) but 2.1.3-18 is to be installed
>                                           ^^^^^^^^
>           Depends: xlibs (>= 4.0.1-11) but it is not installable
> E: Sorry, broken packages
> fot2:~# exit

> So I figure that I need to somehow upgrade my libc6 to > 2.2.2-2. But
> apt-get says that '2.1.3-18 is to be installed' !?
> How do I get it to upgrade my libc6?

For some reason, apt doesn't want to upgrade libc6 automatically.  Try an
`apt-get install libc6`; it'll probably just go right through, but you
may get some warnings that point at why apt wanted to leave it alone.
You should upgrade it, in any case.  The current stable version is
2.2.2-4, so I'm not even sure that 2.1.3-18 is still available.

That's not gibberish...  It's Linux. - Byers, The Lone Gunmen
Geek Code 3.12:  GCS d? s+: a C++ UL++++$ P++>+++ L+++>++++ E- W--(++) N+
o+ !K w--- O M- V? PS+ PE Y+ PGP t 5++ X+ R++ tv+ b+ DI++++ D G e* h r y+

Reply to: