[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

V4L, Xirlink camera problems

I recently bought a Xirlink (IBM) PC Camera and after reading as much 
documentation as I could find compiled the 2.4.3 kernel with usb support and 
the ibmcam driver.  According to the information at 
http://www.linux-usb.org/ibmcam/ and my /proc/bus/usb/devices, my camera is a 
Model 2, supported by the driver that comes with the kernel.  The module 
loads fine and at least thinks its being used,

niels:/usr/doc/kernel-doc-2.4.3/Documentation/usb# lsmod
Module                  Size  Used by
ibmcam                 23920   1
pcnet32                11536   1
via82cxxx_audio        17120   1
ac97_codec              7808   0  [via82cxxx_audio]

when I have xawtv running, but for the life of me I cannot get any images 
from the thing.  I know the computer is talking to the camera because the 
light on the camera lights up every time I try to use it, but I get 
consistent errors no matter what I do.

I'v tried various programs but none work and xawtv gives the most verbose 
errors so I'll give the results of that.  I'v loaded the ibmcam module with 
various videosize settings, and tried to match that with what xawtv expects:

niels:/# modprobe ibmcam videosize=1
niels:/# xawtv -remote -geometry=352x288 -bpp 8
This is xawtv-3.43, running on Linux/i686 (2.4.3)
x11: remote display (overlay disabled)
wmhooks: netwm
/root/.xawtv:1: error: no section
no infrared remote support available
ioctl: VIDIOCMCAPTURE(0,fmt=0,size=0x0): Invalid argument
ioctl: VIDIOCMCAPTURE(0,fmt=5,size=64x48): Invalid argument
v4l: oops: got sigalarm
ioctl: VIDIOCSYNC(0): Interrupted system call
ioctl: VIDIOCMCAPTURE(0,fmt=1,size=64x48): Invalid argument
ioctl: VIDIOCMCAPTURE(0,fmt=7,size=64x48): Invalid argument
grab: no match for: 384x288 32 bit TrueColor (LE: bgr-)
ioctl: VIDIOCMCAPTURE(0,fmt=7,size=64x48): Invalid argument

the -remote option is to turn overlay off which insisted on giving an error 
as well.

It seems that xawtv is stubborly trying to capture images (or video, 
whichever I try once in the program itself) at 384x288 and 32 bit color, 
despite my explicit command line request that it not do so.  Obviously I 
don't understand whats goin on here...  That sigalarm doesn't look friendly 

Any help?



Reply to: