[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

kernel-package/menuconfig problems

i haven't until recently been attempting to share kernel source trees 
accross systems (e.g. tar/gzip the source tree, scp it over and 
uncompress it or make kernel packages via the kernel-package package). 
but it never seems to work right. trying to run menuconfig fails on the 
copied source tree.

one thing i haven't tried is to copy over a source tree that hasn't 
been touched by the kernel-package package.

this is the error i get when i run make menuconfig:
aphro:/usr/src/kernel-source-2.2.18# make menuconfig
rm -f include/asm
( cd include ; ln -sf asm-i386 asm)
make -C scripts/lxdialog all
make[1]: Entering directory `/usr/src/kernel-source-2.2.18/scripts/lxdialog'
make[1]: Leaving directory `/usr/src/kernel-source-2.2.18/scripts/lxdialog'
/bin/sh scripts/Menuconfig arch/i386/config.in
Using defaults found in .config
Preparing scripts: functions, parsingscripts/Menuconfig: line 1: 13374
Segmentation fault      awk "$1"
Awk died with error code 139. Giving up.
.......scripts/Menuconfig: ./MCmenu6: line 249: unexpected EOF while looking
for matching `"'
scripts/Menuconfig: ./MCmenu6: line 250: syntax error: unexpected end of file
.scripts/Menuconfig: ./MCmenu7: line 86: syntax error: unexpected end of file

Your kernel configuration changes were NOT saved.


(i do get to the menuconfig screen however there are no options other then
load config and save config). if i erase .config, i get the same thing.

and if i try to make bzImage for example off the kernel-source package
i get:

aphro:/usr/src/kernel-source-2.2.18# cp /boot/config-2.2.18 .config
aphro:/usr/src/kernel-source-2.2.18# make bzImage
gcc -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -o
scripts/split-include scripts/split-include.c
make: *** No rule to make target `include/linux/autoconf.h', needed by
`include/config/MARKER'.  Stop.

the config file is from the same kernel, and even if i try any of the
i get the same:
make dep
make clean
make mrproper
(and then attempt a make bzImage)

everything results in the same error. this isn't the first time i've had this
problem but i have time to ask so does anyone know what could be going
on here?

i've been compilin linux kernels since early 97 or so..can't count
how many i've done and have never had this problem. Now if i tar
up the original source and gzip it, scp it over and decompress I
*can* make bzImage but i cannot still run menuconfig. The only
thing i can think of is somehow kernel-package must be mangling the source.

btw, all of my systems are potato 2.2r2, and if i didn't mention
above i have had it happen on every system i've tried it with.



ICQ: 75132336

Reply to: