[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Help: apt-get -f install



On Wed, Mar 28, 2001 at 10:57:25AM -0600, destruss@rconnect.com wrote:
> Hi Christian:
>  I take you tried :
> apt-get -f install
>  and it continued to give the loop?

Hi,

I had a play around with dpkg -i --force-overwrite perl-suid_5.6.0-21_i386.deb

output:
------
dpkg: considering removing perl-5.004-suid in favour of perl-suid ...
perl-5.004-suid is not properly installed - ignoring any dependencies on it.
dpkg: yes, will remove perl-5.004-suid in favour of perl-suid.
(Reading database ... 74362 files and directories currently installed.)
Unpacking perl-suid (from perl-suid_5.6.0-21_i386.deb) ...
/var/lib/dpkg/info/perl-5.004-suid.postrm: suidunregister: command not found
dpkg: error processing perl-suid_5.6.0-21_i386.deb (--install):
subprocess post-removal script returned error exit status 127
Errors were encountered while processing:
 

> Does throwing some -v give any more clues?

no...nothing extra anyway. 


> Can you reinstall perl-5.004-suid to get rid of the 
> dependencies error? HTH    Dean

No luck. The old perl-suid depends on the old perl, but dpkg -i --force-downgrade perl-5.004_5.004.05-6.deb fails because of other dependencies. I might try dpkg -iB --force-downgrade perl-5.004_5.004.05-6.deb to see if --auto-deconfigure helps.  


output1:dpkg -i perl-5.004-suid_5.004.05-6.deb
----------------------------------------------
Selecting previously deselected package perl-5.004-suid.
Preparing to replace perl-5.004-suid 5.004.05-6 (using
perl-5.004-suid_5.004.05-6.deb) ...
Unpacking replacement perl-5.004-suid ...
dpkg: dependency problems prevent configuration of perl-5.004-suid:
perl-5.004-suid depends on perl-5.004 (= 5.004.05-6); however:

ouput2:dpkg -i --force-downgrade perl-5.004_5.004.05-6.deb
----------------------------------------------------------
dpkg: considering removing perl in favour of perl-5.004 ...
dpkg: no, cannot remove perl (--auto-deconfigure will help):
perl-5.005 depends on perl (>= 5.6.0-20)
perl is to be removed.
dpkg: regarding perl-5.004_5.004.05-6.deb containing perl-5.004:
perl conflicts with perl-5.004
perl-5.004 (version 5.004.05-6) is to be installed.
dpkg: error processing perl-5.004_5.004.05-6.deb (--install):
conflicting packages - not installing perl-5.004
			 

-- 
kind regards

Christian



Reply to: