[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Upgrade to Perl 5.6 broke my Apache.

I'm running a 'testing' distro system. I recently
upgraded the perl package to 5.6, and now Apache won't
start because of perl problems. Here's the error

leid:~> apachectl configtest
[Fri Mar  9 15:22:01 2001] [error] Can't locate
strict.pm in @INC (@INC contains:
/usr/lib/perl5/5.005/i386-linux /usr/lib/perl5/5.005
/usr/local/lib/site_perl /usr/lib/perl5 . /etc/apache/
/etc/apache/lib/perl) at
/usr/lib/perl5/5.005/i386-linux/Apache.pm line 3.BEGIN
failed--compilation aborted at
/usr/lib/perl5/5.005/i386-linux/Apache.pm line 3.
Syntax OK

What I gather from this is that while my perl is 5.6,
for some reason, it still has the old include paths.
My question is, how can I update @INC?


Do You Yahoo!?
Get email at your own domain with Yahoo! Mail. 

Reply to: