[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Strange /dev/pts/ problem -- solved (sort of)

Reminder -- The problem was the following:

If no terminal is already opened and an ordinary user tries to open a
wterm, it will fail with the message: "wterm: can't open slave tty
/dev/pts/0". It would work if root tries to open it. Likewise, an ordinary
user cannot open /dev/pts/1, but root can. At this point, it gets really
strange: assume that root has already opened two terminals, so that the
first free slave terminal is /dev/pts/2. This one (and apparently all the
terminals numbered above 1) can be opened by an ordinary user...


After experimenting, it became clear that devfsd was the culprit: turning
it off solved the problem. In fact, I had set it to store in /dev-state/
the permissions of newly created devices, and restore automatically these
permissions later. Problem: it has been doing that also for the slave
terminals. It happened that /dev-state/pts/0 and /dev-state/pts/1 belong
to root... They were therefore recreated with ownership root, because of
my setup of devfsd, and an ordinary user could not open them.

For the time being, I just turned off this feature of devfsd, and cleaned
up /dev-state/ and that solved my problem. I still have the following
question: I would like to be able to use this feature of devfsd
(automatically save/restore the permissions of some devices) because it is
useful in some instances, but would like to avoid any nasty interference
with the /dev/pts/'s. How should I setup the config file devfsd.conf ?


François Gelis / BNL - Nuclear Theory / gelis@bnl.gov

Reply to: