[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: XFree86 4.0.2 upgrade

On Sat, Feb 17, 2001 at 08:41:10PM -0500, Manaen Schlabach wrote:
> Recently I installed XFree86 on my Intel box in the hopes of getting the
> NVIDIA drivers up and running.  I changed the config files for apt to
> point to the unstable distro and did the upgrade but it didn't seem to
> work.  Currently I can't even get X up and running and am thinking about
> reinstalling potato, however I would like to avoid that.  Here is the
> error message I get.
> X: cannot stat /etc/X11/X
> After checking I find the file does exist under /usr/X11R6/bin/X.  I
> tried to simply copy it to the etc/X11 no luck.  Tried to create a
> symlink in X11 no luck.  Copying it I get a message like this:
> waiting for X server to begin accepting connections

I had that problem. Woody X upgrade is little buggy.
/usr/X11R6/bin/X should be a Debian wrapper (xserver-common):

-rwsr-sr-x    1 root     root         6764 gru 25 06:39 /usr/X11R6/bin/X

/etc/X11/X should point to you real Xserver:

lrwxrwxrwx    1 root     root           20 lut  9 11:08 /etc/X11/X -> /usr/bin/X11/XF86_S3

(I use S3/3.3.6 from woody, use xserver-xfree86 for real 4.0.2 xserver)


Reply to: