[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Any experience with new NVIDIA drivers?

On 04 Feb 2001 20:01:20 -0600, Dr. Aldo Medina wrote:
> I'm using a Gigabyte 6XOM7E-1 Mobo with a Creative Labs Graphics Blaster
> Riva TNT. Debian 2.2r2 testing. I just installed the nvidia 0.9-6 from
> tarball. I followed the instructions in NVIDIA_Linux.html, including
> renaming /usr/X11R6/lib/modules/extensions/libGLcore.a,
> /usr/X11R6/lib/modules/extensions/libglx.a, /usr/X11R6/lib/libGL.so* and
> libGLcore.so*. I didn't had any /usr/lib/libGL.so file. When I tried
> xscreen-demo GL savers, the speed was very slow, so I tried searching
> for Mesa* files and I renamed libMesaGL.so.3 and libMesaGLU.so.3. I made
> a symlink from libMesaGL to /usr/lib/libGL.so.1, and from libMesaGLU.
> Now when I try GL savers, I get a shared library not found relating
> libGLU.so, so I deleted the libMesaGLU symlink. No success. Any ideas?

No problems here. The glx tarball does everything for you. The steps
related to Mesa that are needed with rpms are obsolete. The library
links should be set up by ldconfig automatically. I you read carefully,
you'll see that a /renaming/ of libMesaGL* is not needed anyway, you
remove them (not needed when installng from tarball)

>From the FAQ:
5.2.2 Install from tar file

Using the tar file simply requires untarring the file, and typing 'make'
in the resulting directory. The Makefile will remove conflicting
libraries, install the libraries into the correct location for you, then
run "ldconfig"

did you remember to change
Driver "nv"
Driver "nvidia"
in your XF86Config or XF86Config-4?

You should reread the instructions carefully. It would help if you
posted the relevant (not working) sections of your
/var/log/XFree86.0.log for inspection


I did not vote for the Austrian government

Reply to: