[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Moved system partitions--> weird /dev/hdaX???

Sorry 'bout the length of this, but I'm a bit stymied and also anxious about
this oddity.  I'd appreciate some insight, if any is forthcoming.

Newbie approach to giving new partition to Nintendo, er, Winblows 98 for
games.. I have at least one really strange /dev file now, for hda3.

I was partitioned as
/dev/hda1  3 Gb for M$ (primary)
/dev/hda3  15 Mb for /boot (primary)
/dev/hda5  100 Mb for / (logical)
/dev/hdaxx for others down the list (swap, var, usr, home, scratch)

I am now with
/dev/hda1 as above
/dev/hda3 4.5 Gb D: for M$ (primary)
/dev/hda5 for / (logical), contains boot files now instead of separate part.

/dev/hda3 now mounts as the old boot directory.  ????  And I can read the

Does this have something to do with the tar process (used to move / ), or...

The long story:

With a 20 Gb HD I shifted all but / and /boot partitions down slowly to end
of drive.  All worked well.

Made a new / partition by tar'ing / with an exclude on proc, home, usr, var.
This part. is inside the logical drive, not at the front edge, but within
first 8 Gb of the HD. Rebooted, but had lilo.conf pointing at old root part.
with fstab pointing at new (don't ask... it's late).  I thought I was
changing files on new partition, but apparently hit the old one.

That became clear when I tried shifting /boot onto the root partition.
Didn't know how to umount /boot, so copied the boot dir to a temp one,
then booted with an installation disk, mounted / and the usr partition
(holding the boot files), and copied the files into boot. Rebooting off the
HD died, with unmodified /etc/fstab files freaking the system out. Redid the
files (how did lilo.conf work with the wrong params?  Or did running off the
"bogus" partition do the right thing anyway?) and the system seems normal,
except for /dev/hda3.

Final work involved trashing all earlier, now unused partitions into one
large one for M$. That's been formatted. Booting into Debian gave me the
freaky /boot partition.  Haven't checked anything else.

Is something deadly wrong, or (Please :) is this a simple issue I know
nothing about??

Thanks very much,

It is not so very important for a person to learn facts.  For that he
doesn't really need a college education, for he can learn them from
books.  The value of an education in a liberal arts college is not the
learning of many facts but the training of the mind to thinking--something
that cannot be learned from books.     Albert Einstein

Reply to: