[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: GD::Image does not support PNG

On Tue, Jan 23, 2001 at 04:56:58PM -0200, Fabio Berbert de Paula wrote:
> Hi,
> I'm trying to make the GD Graphics Library works
> with PNG format support in my perl scripts.
> The following packages were installed in my Debian
> Potato:
> libgd-perl 1.18-2.1
> libgd1g  1.7.3-0.1
> libgd1g-dev 1.7.3-0.1
> libpng2  1.0.5-1
> libpng2-dev 1.0.5-1
> But when I run my script I get this error message:
> Can't locate object method "png" via package 
> "GD::Image" at ./grafico.pl line ***
> where *** = print FILE $im->png;
> The syntax of script is corretc. I tested
> it in other machine, where I installed the
> packages via tarball.
> Some idea?!? ;o)

maybe you have the wrong mix of versions...

I think that versions up to something around 1.19 of libgd-perl
did not support the PNG format (instead they did support the GIF
format that's been taken out in later versions because of patent
issues. These older versions are probably still around for people
who need/want GIF support)

Try to find a newer version of the GD Perl module (current version
is 1.32) ...
The version 1.7.3 of the C-library the Perl module is based upon,
should be ok, I guess -- though the most recent version is 1.8.3.


Erdmut Pfeifer
science+computing gmbh

-- Bugs come in through open windows. Keep Windows shut! --

Reply to: