[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: mouse middle button not working in X

If you have usb ports, I recommend the Belkin 3-button mouse. See: http://catalog.belkin.com/IWCatProductPage.process?Merchant_Id=1&Section_Id=38&pcount=&Product_Id=22121&Section.Section_Path=%2FUSB%2FMultimed%2E%2E%2Eeyboards%2F

There are clear instructions for setting up usb devices at

And you get real 3-button function.


Anthony Campbell wrote:

On 02 Dec 2000, Jeremiah H. Savage wrote:

When I was using a ps/2 mouse, I got the middle buttom to work by changing the Device in the "Pointer" Section of /etc/X11/XF86Config from Device "/dev/psaux" <-- yours might have something else
Device "/dev/gpmdata"


Anthony Campbell wrote:

I have a 3-button mouse; Microsoft-compatible. It works as expected in
the console but the middle button doesn't work in X.

Also, I have to turn it off in the console when I'm in X, otherwise the
pointer freezes.

Any ideas about this?


Yes, I used to have "/dev/gpmdata" as well at one time. I tried it again
now and it does allow the mouse to work both in console and X. However,
the middle button still doesn't work, but I've gone back to a 2-button
genuine Microsoft mouse which can at least emulate 3 buttons (essential
for xfig).

Reply to: