[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problem with dpkg/perl and so ;)



François-Xavier Houard <idefx@iname.com> writes:

> Hi
> i've got a huge problem, dpkg seems to bug when i try to install some
> packages, i can't install debconf, i get this message:
> Data::Dumper object version 2.101 does not match $Data::Dumper::VERSION 2.09 at /usr/lib/perl5/5.6/i386-linux/DynaLoader.pm line 219.
> Compilation failed in require at /usr/lib/perl5/Debconf/ConfigDb.pm line 82.
> BEGIN failed--compilation aborted at /usr/lib/perl5/Debconf/ConfigDb.pm line 82.
> Compilation failed in require at /usr/share/debconf/frontend line 24.
> BEGIN failed--compilation aborted at /usr/share/debconf/frontend line 24.
> dpkg: error processing debconf (--configure):
>  subprocess post-installation script returned error exit status 2
> Errors were encountered while processing:
>  debconf
> 
>  I don't really know what to do, if anyone could help me, that would help
>  me much ;))
> 
> 
>  Thanks 
> 
> 
> François-Xavier

I had a similar problem yesterday upgrading from potato to woody. The way I
solved it was by installing individually the packages which I thought might be
broken:

apt-get install debconf
apt-get install perl

until I was able to fix the broken component and complete the unpacking,
installing, and setting up of apt-get dist-upgrade. I did it by trial and
error (try whatever sequence you prefer) until things started working again.

Good luck,
-- 
Giulio Morgan
mickle@panix.com



Reply to: