[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: I can burn CDs, but can't mount any CDs.

>>>>> "TH" == Terry Hancock <hancock@earthlink.net> writes:
    TH>  I was never able to make the above fix work (i.e. have both
    TH> ATAPI/IDE CD-ROM and a ide-scsi CD-RW).  However, the penalty is
    TH> not so awful: it's just that the CD-ROM is now a SCSI device.  I
    TH> used to have the CD-ROM as /dev/hdc, but after installing
    TH> ide-scsi support, it and the CD-RW are /dev/scd0 and /dev/scd1
    TH> respectively, for mounting disks.  The CD-RW is refered to as
    TH> /dev/sg0 though, when I write to it.
    TH> In general, scd# is a "SCSI CD Device" and sg# is a "SCSI
    TH> Generic Device".
    TH> The original poster can probably solve his problem by changing
    TH> the /dev/cdrom symlink to point to the correct device.

Thanks for pointing that out Terry. That has solved my problems.

John, it was easier to change the /dev/cdrom symlink than to recompile
the kernel. When I had IDE/ATAPI CD-ROM support alongwith SCSI emulation
(and a bunch of other options) for the Yamaha CD-RW, X-Cdroast was
unable to find any SCSI devices and wouldn't work. But removing
IDE/ATAPI CD-ROM support solved the problem and X-Cdroast works
perfectly now.

Thanks your replies John, Terry.

Now back to getting ATA100 support working for my ASUS-CUSL2 board ...

Salman Ahmed
ssahmed AT pathcom DOT com

Reply to: