[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

apache, perl, 403 forbidden, help?

hi all.

i can't get apache to execute a perl/cgi script.

*box: potato/sparc, installed apache-perl and its dependencies.

*error: 403 forbidden in web browser. this in error log:

   Options ExecCGI is off in this directory: /home/herb/public_html/init/login.pl

i tired everything in the faq and manual to little success. things
i've tried:

1) i've added the handler and options directives to my srm.conf:

      AddHandler cgi-script .cgi .pl
      <Directory "/">
         Options +All +ExecCGI

   i know +All and +ExecCGI are redudant and this is not secure, but
   i'm desperate. =) 
2) i tried pointing the directory to the exact directory where i'm
   executing the script (i.e. "/" -> "/home/herb/public_html/init", my
   script resides in init/) to no avail.

3) i tried replacing the <Directory> directive w/

      ScriptAlias ~herb/public_html/init /home/herb/public_html/init

   again, no effect.

4) installing the 'apache' package instead of 'apache-perl'. it makes
   me download the script.

permissions look correct. all parents of the script directory are at
least o+rx. i am able to execute scripts ok in /usr/lib/cgi-bin/
(ScriptAlias'ed to cgi-bin/), but not elsewhere.

HELP? any is appreicated...


Reply to: