[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

potato i386. apache segfault after jserv deinstallation



hia,

yesterday i migrated a website to debian potato. apache (from
official deb binaries) excecuted with the new configuration, no
probs.

then i saw that both cocoon and jserv did not configure properly
(but i did not expect anything else as i have not set them up).
to get rid of the apt-get/dselect-problem related to these two
packages (i could not install anymore packages) i tried to remove
both packages. cocoon went fine, but jserv told that it did not
find any user 'www-date'. as i have not seen any good use of
www-data anyway (i run apache as wwwrun.www) i just removed the
user 'www-data' and thus apt-get/dselect worked again.

but then i recognized that apache did not run anymore. i tried to
start apache with different flags, it always segfaulted after
about a second. i tried to re-add user and groups 'www-data',
adjusted shadow, gshadow etc. re-installed/-configured jserv
several times, but apache still did not work. 

what can i do now? 'apt-get check' showed no failed dependencies,
'/usr/sbin/apache -t' says the syntax of /etc/httpd.conf is ok.
what could be wrong (the syntax and actually also the semantics
of /etc/httpd.conf were right)? which packages should i
reinstall/-configure? how dangerous is this if i already migrated
the webcontent undr /var/www and the configuration under
/etc/apache. what are the purposes of the user 'www-data' and the
group 'www-data' and what are their proper settings in
/etc/passwd, /etc/shadow, /etc/group, /etc/gshadow? did anybody
have a similar experience after removing modules from apache?

hope you can help me. rgds

--dani

--
Daniel Mettler                  http://www.icu.unizh.ch/~mettlerd

All general statements are false. (The Ultimate Law)



Reply to: