[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Debconf/Perl-upgrade fails



As a result of trying to install Xfree-4 ,apt-get installed/removed a 
raft of packages. 

The install process finally produced these errors

------
Need to get 0B of archives. After unpacking 0B will be used.
Setting up debconf (0.5.21) ...
Can't locate warnings/register.pm in @INC (@INC contains: /usr/lib/perl5
/usr/lib/perl5/5.6/i386-linux /usr/lib/perl5/5.6
/usr/local/lib/site_perl/i386-linux /usr/local/lib/site_perl
/usr/lib/perl5/5.005/i386-linux /usr/lib/perl5/5.005 .) at
/usr/lib/perl5/5.6/vars.pm line 11.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.6/vars.pm line 11.
Compilation failed in require at /usr/lib/perl5/5.005/lib.pm line 3.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.005/lib.pm line 3.
Compilation failed in require at /usr/share/debconf/frontend line 21.
BEGIN failed--compilation aborted at /usr/share/debconf/frontend line 21.
dpkg: error processing debconf (--configure):
 subprocess post-installation script returned error exit status 2
 dpkg: dependency problems prevent configuration of libglide2:
  libglide2 depends on debconf (>= 0.3.74); however:
    Package debconf is not configured yet.
    d
------
followed by a list of packages failed because debconf was not installed.

I don't understand whether its a problem of debconf or perl. 
What do I need to do, if anything or just wait until updated versions of the
packages are available?

If this sounds as if I am bushed you are so right.
  
		    ----russ----
		    



Reply to: