[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problems with Matrox G400 AGP

I have the same card with a 750 Duron (KT7-RAID m/b) and started having the
similar problems (hard lock, no virtual console, no ctrl-alt-delete, black
screen, etc) but only within the last few days. Everything was working
beautifully under XFree 4, even under high resolutions and medium graphic
intensive programs, until I updated my packages a few days ago. I'm assuming
that something broke with the mga drivers and hoping that it will be fixed
soon. There has been a lot of activity with woody debs with regards to X
stuff, so we'll just have to wait and see. However, that doesn't explain why
it won't work under 3.3.6 for you, because I ran it for about a month with
no problems on that.

Thinking maybe I should go get the latest driver from off their website.

Charles Lewis

> Dear all.
> I've just bought a new computer and I've choosen a Matrox
> Millennium G400 AGP card (as they're one of the most open
> source friendly companies out there).
> Everything seems to be working fine with my hardware (I've got
> an Asus A7V and a Duron 600 and they're working like a champ),
> *except* that I can't seem to use my card in any graphic mode.
> :-(
> I've tried to use both XFree86 3.3.6 and 4.0.1e (Branden's
> packages from Debian) and after working for 2 or 3 *seconds*,
> the whole machine hangs *hard*: no desktop switching, no
> ctrl-alt-fx, no magic sysrq, no life, no nothing. :-(
> But some strange facts actually happen:
> 1 - when using XFree with a low resolution, 640x480 with 16
>     colors (like when I'm running XF86Setup), everything works
>     ok;
> 2 - the *worst* part: windows works fine even with very, very
>     high resolutions and a considerable amount of time (I
>     don't have games here to test really intensive use of the
>     card).
> Incidentally, FreeBSD 4.1.1's XFree 3.3.6 also has the same
> problem that Linux has (which seems to indicate that something
> must be wrong with XFree or with my card -- memory? -- that
> may be being triggered by XFree).
> The last fact, the Linux's Matrox framebuffer driver also
> hangs the machine. :-(
> So, I'd like ask you if you have any suggestions or if anybody
> has seen anything similar to this admitedly strange situation.
> Any hints or ways to check if the hardware is defective are
> more than welcome, since I'm a bit desperate to return the
> card if it indeed has a problem.
> Thanks in advance for any help, Roger...
> P.S.: I'm a newbie when it comes to AGP cards as this is the first one
> that I have ever used -- so, if there is anything that I could change
> in the BIOS, please let me know.
> P.S.2: I'm including the output from XFree right after it came up, but
> before it hanged (finished it with control-alt-backspace).
> --
> =-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
>   Rogerio Brito - rbrito@ime.usp.br - http://www.ime.usp.br/~rbrito
> =-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

Reply to: