[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

How can I force the removal of a package?



I am following unstable and currently have a problem with
9menu_1.4-10_i386.deb. It will neither upgrade with apt nor allow itself
to be removed with either apt or dpkg.

I get this message:

dpkg (subprocess): unable to execute old pre-removal script: Exec format
error
dpkg: warning - old pre-removal script returned error exit status 2
dpkg - trying script from the new package instead ...
dpkg (subprocess): unable to execute new pre-removal script: Exec format
error
dpkg: error processing /var/cache/apt/archives/9menu_1.4-10_i386.deb
(--unpack): subprocess new pre-removal script returned error exit status
2
dpkg (subprocess): unable to execute post-installation script: Exec
format errordpkg: error while cleaning up:
 subprocess post-installation script returned error exit status 2
Errors were encountered while processing:
 /var/cache/apt/archives/9menu_1.4-10_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I can't re-install the old version, nor the new one. I don't actually
need 9menu any more so would like to simply blitz it altogether. Any
ideas how I can get rid of it? It is causing a blockage so that whatever
I now do with apt-get it rears its ugly head.

Cheers.



Reply to: