[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Dual RTL Nic Issue for MASQ machine

Hello All,

I am attempting to build a small firewall/proxy/masq computer for my home network. I am having a problem when I attempt to ping to and from the INTERNAL NIC on my Linux machine to and from an INTERNAL masq machine. I believe this to be a software issue and not a hardware issue for several reasons:
1) I can connect to the internet using the external NIC on the Linux machine
2) My machines dual boot with Win98, and when I boot into Windoze I can ping to and from all NICS on the Linux box to and from all NICS on the Windoze box 3) I can use some crappy Windoze proxy software using the dual NICS with no problem

My setup and things I have tried to fix the issue myself:
+I am using dual nics: eth0 is RTL8139, and eth1 is RTL8129
+The kernel is built according to the IPMASQ HOWTO, and support for the RTL nics is built into the kernel +As per the instructions I found in the Ethernet HOWTO I have added the following line to my lilo.conf: append="ether=10,0xb800,eth0 ether=9,0xc000,eth1" +when I do a "dmesg | grep eth" I can see that both the nics have been found, and they report the same IRQ and I/O as I specified in my append command. I also get a line that says "eth1: No MII transceivers found! Assuming SYM transceiver." Not quite sure what this means however... +also in my "dmesg" I see the following error: "Loading modules: rtl8139 modprobe: Can't locate module rtl8139". I guess I don't understand why a module is being loaded when I compiled this into the kernel... +when I do a "ifconfig" both NICS are reported as being up and running, and both NICS have the IP addies I gave them in the /etc/network/Interfaces config file. +my rc.firewall is a literal cut and paste of the "Initial SIMPLE IP Masq test for 2.1.x and 2.2.x kernels" out of the IPMASQ HOWTO, and I changed the last line to reflect my internal IP subnet. When I run this rc.firewall I see no errors reported, and IPCHAINS -L does give me output that all prot all allowed to anywhere. I removed the line about Denying anything, so it is wide open. +I have tried setting ip_foward to both yes and no in my /etc/network/options file +I also went so far as to add "ANY:ANY" to my hosts.allow file, and remove all entries from my hosts.deny file. +I have read the Ethernet, IPMASQ, and Networking HOWTOs. I have also searched the mailing list archives and searched through the Deiban FAQ.

So, can anyone see/guess what is going wrong here? I have a strong feeling that it is related to the module error reported in dmesg, but that's just my newbie guess. ;)

Any help would be muchas gracias appreciated!!


Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com.

Share information about yourself, create your own public profile at http://profiles.msn.com.

Reply to: