[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Unidentified subject!

Subject: Re: dhcpcd weirdness
References: <EA8317922010E2BE852569750048B19D.0047B58885256975@maclaren.com>
	<39E46979.8C4B4D13@MacLaren.com> <002301c03397$7ed15460$0201a8c0@CI15097A>
Reply-to: dwalter@syr.edu
From: David Walter <dwalter@syr.edu>
Date: 12 Oct 2000 13:30:36 -0400
In-Reply-To: "Andrew Whitlock"'s message of "Wed, 11 Oct 2000 11:25:31 -0400"
Message-ID: <877l7enf0j.fsf@eaglepeak.ecs.syr.edu>
Lines: 58
User-Agent: Gnus/5.0807 (Gnus v5.8.7) XEmacs/21.1 (Channel Islands)
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii

>>>>> "Andrew" == Andrew Whitlock <astrogeek@dork.com> writes:

    Andrew> Well, I guess I _could_ use a shell script to start it,
    Andrew> but it bothers me that it used to work yet suddenly does
    Andrew> not.  The config files sure seem to be written correctly.
    Andrew> I have installed other packages since dhcpcd that mess
    Andrew> with network things, such as ssh and oidentd, but I don't
    Andrew> see how this would affect dhcpcd since it has its own
    Andrew> config file??

I think that I had experienced the same  problem. I had other problems
with my configuration  so I modified  the script I had already  built,
but recently came  across something that made me  think that it wasn't
dhcp per se that was failing, it  was that ifconfig and init.d/network
hadn't  run  prior to the  dhcp  run, or  something wasn't initialized
before dhcp  ran.   A hand start  of dhcp  worked after boot,  later I
modified to  call dhcp   from another  script    ( I think  this   was
effectively why the fix  I had performed  earlier was working,  though
not sure now. )

If that is some help? :) maybe it was a delay time to load a module or
initialize the card?  I know that I had problems similar  to this on a
laptop with potato or woody installed.

    Andrew> Debian does default to pump, but I removed it as I could
    Andrew> never get it to work.  dhcpcd worked on the first try,
    Andrew> with the caveat that "-h (hostname)" must be used with my
    Andrew> ISP.  The config file even worked, back then...

    Andrew> Does anybody think that upgrading to the version in
    Andrew> unstable might do something?  I've already tried purging
    Andrew> and reinstalling potato's version (including the files in
    Andrew> /etc/dhcpc).

    Andrew> Andrew W.

    Andrew> ---- Original Message ----- From: "Jason Hammerschmidt"
    Andrew> <Jason.Hammerschmidt@MacLaren.com> Sent: Wednesday,
    Andrew> October 11, 2000 9:22 AM Subject: Re: dhcpcd weirdness

    >> I have no problems with Rogers@Home service and my DHCP
    >> service, albiet, I
    Andrew> use
    >> the command line -h not config files.
    Andrew> <<SNIP>>
    >> I just put dhcpcd -h cr-<your#'s> & in rc.local and all is
    >> fine.  Doesn't debian use pump though?

    Andrew> -- Unsubscribe?  mail -s unsubscribe
    Andrew> debian-user-request@lists.debian.org < /dev/null

/ \ 

Reply to: