[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problems installing X

I had problems installing X, and as I am new to Debian - though not Linux,
I'd like to know if it was something I did or whether the Debian setup is
not right.

I previously installed 2.2 from a 2 CD set.  Then I ran XF86Setup.  When I
chose the Diamond V770 (TNT2) from the hardware list, it told me I needed
to get the svga driver.  So, using apt-cache -search I found the
xserver-svga deb.  I then ran apt-get -install xserver-svga.

This time XF86Setup went to completion and I thought I had a winner.
Unfortunately, when it tried to connect to the server I got multiple errors of
this sort: X11TransSocketUNIXConnet.  My guess was that the server had not
really been installed or the setup was pointing to the wrong server.

I tried to get apt-get to tell me what it had installed when I ran apt-get
-install xserver-svga, but I couldn't figure out how to do that from the man

I finally got things working by running xf86Config (which told me it was
changing something in /etc/X11/xserver (I think thats the right file).  Is
that file a Debian thing?  I seem to recall that Redhat and Mandrake used a
soft link for something similar.

After that X would run but I found X keyboard errors when exiting X.  Running
XF86Setup again and making sure the keyboard stuff was modified fixed that
problem also.

So now I have a working X situation, but I want to know:  Should apt-get or
XF86Setup have modified that /etc/whatever file?  Was I supposed to know to
change it?  If so, where is that documented?

Thanks.  You all have already been a wonderful resource.


Draco Dormiens Nunquam Titillandus (Never Tickle a Sleeping Dragon)
  -- Hogwarts School Motto

Reply to: