[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

yp problem. Please help!

I just downloaded the new nis package. It installed fine. Now, when
I run ypbind -debug, I get this:

43 ROOT ruchetta ~>ypbind -debug
parsing config file
Trying entry: ypserver fava.idsia.ch
parsed ypserver fava.idsia.ch
add_server() domain: idsia.ch, host: fava.idsia.ch, nobroadcast, slot: 0
Trying entry: domain idsia.ch
parsed domain 'idsia.ch' broadcast
add_server() domain: idsia.ch, broadcast, slot: 0
[Welcome to ypbind-mt, version 1.6]
Cannot register service: RPC: Unable to receive; errno = Connection refused
Unable to register (YPBINDPROG, YPBINDVERS, udp).       


Before I upgraded to woody, yp worked fine. Also, yp works on our redhat
machines. I grabbed the redhat ypbind binary and tried it. Same error. When
I do a strace, this is what I see. Why Seems like I'm refusing my
own RPC service registration? What gives?: 

port=htons(111), sin_addr=inet_addr("")}}, 16) = 56
poll([{fd=7, events=POLLIN, revents=POLLERR}], 1, 5000) = 1
recvfrom(7, 0x8056ec8, 400, 0, 0xbffff92c, 0xbffff8d8) = -1 ECONNREFUSED (Connection refused)
write(2, "Cannot register service: RPC: Un"..., 76Cannot register service: RPC: Unable to receive; errno = Connection
) = 76
write(2, "Unable to register (YPBINDPROG, "..., 49Unable to register (YPBINDPROG, YPBINDVERS, udp).) = 49
write(2, "\n", 1
)                       = 1
write(5, "\200\230\2@\2\0\0\0\1\0\0\0\4\255\21@\204O\24@\217\241"..., 148) = 148
rt_sigprocmask(SIG_SETMASK, NULL, [HUP INT QUIT SEGV TERM CHLD RT_0], 8) = 0
rt_sigsuspend([HUP INT QUIT SEGV TERM CHLD] <unfinished ...>
--- SIGRT_0 (Real-time signal 0) ---
<... rt_sigsuspend resumed> )           = -1 EINTR (Interrupted system call)
sigreturn()                             = ? (mask now [HUP INT QUIT SEGV TERM CHLD])
wait4(30253, NULL, __WCLONE, NULL)      = 30253
_exit(1)                                = ?

Reply to: