[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: slrnpull failure

On Fri, Sep 08, 2000 at 01:24:24AM +0200, jakbyto@kki.net.pl wrote:

> Hi,
> I have a problem with slrnpull or to be more precise with its connection
> to ISP. I read file /slrn/slrnpull/QUICK_INSTALL and did all as it is
> written there. So I run my /etc/ppp/ppp-on script to connect to ISP
> (everything goes well as usualy) and when it's done I run slrnpull.
> But all I get is this:
> /usr/sbin/pppd: By default the remote system is required to authentificate
> itself (because this system has a default route to the internet) but I
> couldn't find any suitable secret (password) for it to use to do so.
> (None of the available passwords let it use an IP address).
> But this is only a half of my story (the second half). Because firstly
> I changed two lines in that slrnpull file. In this file there is
> a short script that (as its author says) does: 1. ... ,
> 2. Starts up ppp via a ppp-on script (not provided),
> 3. Runs slrnpull to grap articles from the server, 4 .... .
> And the script that is to do all this job looks as below:
> if /usr/sbin/ppp-on; then
> $slrnpull -d $dir -h server
> /usr/sbin/ppp-off
> else
>  exit 1
> fi
> Because I don't have anything like /usr/sbin/ppp-on(off) on my RedHat6.2
> I changed this to /etc/ppp/ppp-on(off) (these two scripts I use to
> connect/disconnect to the internet). And the score you already know.
> What did I wrong and what am I to change to run slrnpull without any
> problems? And BTW I set an uid bit to my pppd to be able to run it as
> common user. But now I know that this not too good solution and also
> I know that there are some better ways to do it. Could you tell how
> can I do it to run pppd as secure as possible and without any 
> authentification problems.
> Thank you for hepl in advance,
In fact this is not answer to my question but just few minutes ago
I had strange situation that should shed some light to this problem.
Namely when I was online (pppd was running) I typed "pppon" instead of
"pppoff". And guess what response from pppd I got? Exactly the same
as I mentioned before (trying slrnpull - "By default the remote system
is required to ... "). So this means to me that slrnpull must be run
when I'm offline. The problem is that it doesn't want to. When I tried
to run it that way I got note "ERROR: PPP link is not active on ppp0".
Can anyone tell me how to force slrnpull to run correctly?
Thank you in advance,


Reply to: