[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: Mouse Doesn't Work with X

On Wed, 23 Aug 2000, gabe lamarche wrote:
> I had this same thing happening to me.  The problem seems to be some
> kind of conflict with gpm (the terminal mouse package).  I found that
> if I turned stopped gpm my mouse worked fine in X.
> To stop gpm I switch to a virtual consol via Ctrl^ Alt^ F1, logged in
> and issued the comand  killall gpm.  
> Not a great solution, I suppose if you don't need gpm package,
> uninstalling it would also resolve the problem.
> Gabe Lamarche
> gblamarche@yahoo.com 
> Greetings all,
> I just installed my first copy of Linux.
> Problem:
> X starts fine.   I can use ALT key combinations to get a pop up menu 
> and
> select menu items.  However, I can't use my mouse.  That is, neither
> clicking nor moving the mouse has any effect.
> What I did:
> I confirmed that my mouse is, in fact, PS/2.
> I confirmed that my mouse is connected to the correct port.
> I boot Linux.
> I login-ed as root.
> I ran 'xf86config' and selected 'PS/2' as my mouse.
> I started X.
> Mouse doesn't work. :-(
> What I checked:
> A coworker helping me checked the boot log with 'dmesg'.  We found a 
> line
> that says "Detected PS/2 Mouse Port".  Sound like good news...
> We checked to see if the XF86Config file was written write.  Sure 
> enough,
> the mouse is PS/2.  This looks good too...
> My plea:
> I don't know what the heck is going on here.  What could be wrong?  Can
> someone please help?
> If I've commited any Netiquette rudeness or some such, I apologize in
> advance.  I'm new to this! :-)  I think I've described the problem in
> sufficient detail; however, if I've left some important information 
> out,
> then please tell me. I'll be more than happy to respond.
> Thanks,
> Peter
> __________________________________________________
> Do You Yahoo!?
> Yahoo! Mail - Free email you can access from anywhere!
> http://mail.yahoo.com/
> -- 
> Unsubscribe?  mail -s unsubscribe debian-user-request@lists.debian.org < /dev/null

I can't remember which one, but you have to change the script that starts
gpm or the gpm config file to not use the -R flag. It is either the init
script /etc/init.d/gpm or in it's config file /etc/gpm.conf. Also make sure
you have you XF86Config file using the real device (/dev/psaux for PS/2
mouse). You could also tell XF86Config to use /dev/gpmdata, but this is
not guaranteed to work properly all the time.

After starting gpm you can do 'ps aux | less' and if you look you will see
the -Rxxx flag with the gpm process that is the culprit. That is what you
need to turn off.

Daniel E. Baumann
E-mail: baumannd@msoe.edu (preferred)
        baumannd@penguinpowered.com (caution: dynamic DNS service, may bounce)

Web location: 	http://www.msoe.edu/~baumannd

"Life would be so much easier if we could just look at the source code." 

      -- Dave Olson

Reply to: