[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Configuring two of same network card + keyboard not working in X

Debian unstable
Kernel 2.2.17

Two SMC-ULTRA cards, configured for IRQs 10 and 11 (can't remember IO bases
off hand - not near machine right now).

How do I get both cards recognised?

I tried two lines in /etc/modules quoting IRQs and IOs (as it wouldn't
autodetect them).. Only first card is loaded..
smc-ultra io=... irq=...
smc-ultra io=... irq=...

Tried manual insmod from command line for second card, it informs me module
already loaded.

Machine is an old COMPAQ (fun fun).. has Cirrus Logic 5432 chip in it,

When using XF86Setup I can get keyboard going, but it complains about no setup
for display etc.
When using xf86config I can get display going (at least it gives no errors)
but then it complains about keyboard.
I went into XF86Config file and disabled keyboard extensions - no error
messages, but startx still dumps back to prompt - any ideas?

As far as I know, IO base and IRQs for cards do not conflict with anything
else in system (DOS config program run from DOS boot floppy reports both SMC
cards, and successfully configures both of them, reporting no conflicts with
IO/IRQs - second card was on IRQ2/9 [cascade?] - I felt that using 2/9 was a
bit dodgy and changed it to 11 - it didn't work in 2/9 anyway).

Reply to: