[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: still unable to get kernel source

Well, this is what I was doing, but I still have the same problems, please
see below:

On Sun, 13 Aug 2000, Thomas J. Hamman wrote:

> On Sun, Aug 13, 2000 at 09:03:21PM -0500, John Reinke wrote:
> > Okay, I've tried getting the kernel sources from different places,
> > decompressing the files in different ways, and finding the files so I can
> > even start to configure a kernel.
> > 
> > I've done it before, but I guess all the files were already there for me.
> > 
> > Can someone PLEASE just give the step-by-step instructions for downloading
> > and preparing the kernel source? Go ahead and treat me like a
> > five-year-old, I need to get this done right away. I can take over from
> > the "make xconfig" part - I've done that much before.
> > 
> > I am running potato, and would like to use the 2.2.17 kernel if possible.
> Well, the simplest way to go about it..
> 1) apt-get install kernel-source-2.2.17

This seems to have worked:
jupiter:/usr/src# apt-get install kernel-source-2.2.17
Reading Package Lists... Done
Building Dependency Tree... Done
The following NEW packages will be installed:
0 packages upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
Need to get 0B/13.8MB of archives. After unpacking 13.9MB will be used.
Selecting previously deselected package kernel-source-2.2.17.
(Reading database ... 44081 files and directories currently installed.)
Unpacking kernel-source-2.2.17 (from
eb) ...
Setting up kernel-source-2.2.17 (2.2.17pre6-1) ...

> 2) cd /usr/src and tar Ixvf kernel-source-2.2.17.tar.bz2

This is what continues to fail:
jupiter:/usr/src# tar Ixvf kernel-source-2.2.17.tar.bz2
<...skipping down..>

bzip2: Caught a SIGSEGV or SIGBUS whilst decompressing,
        which probably indicates that the compressed data
        is corrupted.
        Input file = (stdin), output file = (stdout)

It is possible that the compressed file(s) have become corrupted.
You can use the -tvv option to test integrity of such files.

You can use the `bzip2recover' program to *attempt* to recover
data from undamaged sections of corrupted files.

tar: 368 garbage bytes ignored at end of archive
tar: Unexpected EOF in archive
tar: Child returned status 2
tar: Error exit delayed from previous errors

It only created three items in the kernel-source-2.2.17 directory before
aborting: COPYING CREDITS Documentation

This is probably why I couldn't configure anything, files are missing. It
aborts early or complains about extra garbage after trying to untar every
kernel source I've tried (both .gz and .bz2), from both debian &

Any suggestions? I have the bzip2 package installed. I've got plenty of
hard drive space. Should I not be root?

> And then from there you should be able to cd into the directory
> it extracted to and start the make xconfig and all that good stuff,
> unless you're missing devel packages for compiling the kernel like bin86
> and libc6-dev, and also tk8.2-dev (that's in Woody, Potato might have
> different version number) if you use make xconfig.
> > If there is a web page that clearly explains this for Debian, I might be
> > able to get a browser going to look at it, but this really should be just
> > a few lines, right?
> My advice:  apt-get install kernel-package (if you don't already have it
> installed) and read /usr/share/doc/kernel-package/README.

Dumb question: should all the documentation within
/usr/share/doc/kernel-package be .gz files? Is there an easier way to view
all the documenation here without having to gunzip them first?


Reply to: