[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Apache w/ Potato, strange .CGI functionality.

Hey all.

I'm not exactly sure if this is a Debian + Apache problem, or just an Apache problem, so if you can point me in the right direction (another list, perhaps?) I'd be most appreciative.

I installed the apache-perl package on my fileserver, and I've configured it for multiple NameVirtualHosts. In a couple of cases, these separate virtual hosts will have separate user directories, demo-www and home-www come to mind, for demo.domain.com/~user and home.domain.com/~user respecitvely.

Everything was working right (or so I thought) until I tried to put CGI's in the ~user directories. I get the frustratingly annoying error: [error] (2)No such file or directory: exec of /home/scriven/home-www/test.cgi failed

I originally thought it was a bad .cgi script, so I copied the one that works (in the main cgi-bin directory) into my home-www directory, and tried again. Same thing.
I tried command line, but it works just fine.
I had a problem with suEXEC, so I've taken it out for now (that was already a bug submitted to the Debian folks, hardcoded public_html directories) I tried setting up the mod_perl stuff, but when I do that, the browser tries to download the output of the CGI script, even though the first thing that is sent is "Content-Type: text/html\n\n"

I've been banging my head against the wall for 2 hours on this problem now.
Does anyone have any pointers for me?

I've seen this work with Apache on other servers, but they may have been separately compiled. I didn't get the apache-dev kit, should I do that and roll-my-own apache?

Thanks very much!
Toronto, Ontario, Canada

Reply to: